Skip to content Skip to main navigation Skip to footer

Xử lý cảnh báo PHP Update Required trên website WordPress

Bỗng một ngày đẹp trời, bạn  truy cập trình quản trị website và nhận được cảnh báo PHP Update Required như hình bên dưới.

Bạn không biết cảnh báo này ý nghĩa ra sao và có ảnh hưởng gì đến website của mình hay không? . Nếu đang hoang mang vì cảnh báo trên, thì bạn không cần quá lo lắng vì đây chỉ là cảnh báo rằng phiên bản PHP website đang sử dụng đã cũ và không còn phù hợp với cấu trúc mã nguồn hiện tại của website nữa (ví dụ: Theme, Plugin, Core WordPress). Cách xử lý là bạn nâng cấp phiên bản PHP mới hơn cho website là có thể giải quyết được vấn đề.

Vậy cách để nâng cấp phiên bản PHP ta cần làm như thế nào, thì ở bài viết này AZDIGI sẽ hướng dẫn bạn chi tiết các bước thực hiện. Các bạn cùng theo dõi các bước bên dưới nhé.

Các bước thực hiện

Bươc 1: Kiểm tra phiên bản PHP hiện tại đang sử dụng

Đầu tiên bạn truy cập vào Hosting, di chuyển đến đường dẫn chứa thư mục website cần nâng cấp. Ở đây website mình thực hiện là azdigi.cf.

Bạn chọn thư mục chứa mã nguồn website (1) => chọn tạo File (2) => Đặt tên file là info.php (3) => Create New File (4).

Sau khi tạo xong bạn nhấn chuột phải và file info.php (1) => chọn Edit (2). Tiếp đó bạn copy nội dung bên dưới và dán vào file info.php nhé.

<?php
phpinfo();
?>

Bạn nhấn Save Changes để lưu lại.

Bây giờ bạn có thể kiểm tra phiên bản PHP hiện tại của website bằng cách truy cập: https://azdigi.cf/info.php (bạn thay azdigi.cf bằng tên website của bạn)

Như hình thì phiên bản mình đang sử dụng là 5.6 , phiên bản này hiện đã quá cũ. Hiện nay đã có các phiên bản 7.x và mới nhất là phiên bản 7.4 rồi nhé.

Bước 2: Nâng cấp phiên bản PHP cho website

Lưu ý: Việc nâng cấp PHP là việc được khuyến nghị, tuy nhiên trong quá trình thay đổi phiên bản PHP, nếu website của bạn xảy ra lỗi, điều đó có nghĩa là mã nguồn của bạn không tương thích với phiên bản bạn chọn. Hãy thay đổi lần lượt các phiên bản PHP (từ mới nhất trở xuống) đến khi website hoạt động và không còn gặp lỗi là được nhé.

Trước khi nâng cấp phiên bản PHP cho website, đầu tiên bạn cần xác định được hiện website của bạn đang sử dụng PHP Selector hay là MultiPHP Manager để thao tác cho chính xác.

Đầu tiên bạn vào Select PHP Version.

Tại giao diện PHP Selector , phần domain cần cấu hình (1) bạn để ý phần HANDLED BY (2) nếu thấy hiển thị hình xoáy màu xanh thì bạn thay đổi PHP bằng cách nhấn vào phần Current PHP version (3) và chọn phiên bản cần nâng cấp => nhấn Set as current để lưu cấu hình.

Còn đối domain có có biểu tượng cP (màu cam) ở phần HANDLED BY  thì bạn cần thoát ra ngoài và tìm đến phần MultiPHP Manager để thực hiện (như hình).

Tại giao diện MultiPHP Manager , bạn chọn domain cần nâng cấp (1) => chọn phiên bản tại PHP Version (2) => Apply (3).

Bước 3: Kiểm tra website và phiên bản PHP sau khi nâng cấp

Bạn vào trình duyệt và truy cập đượng dẫn đã tạo ở bước 1 là https://azdigi.cf/info.php để check phiên bản PHP đã được nâng cấp thành công chưa. Như hình bên dưới là phiên bản PHP đã được nâng lên 7.4 thành công

Bây giờ bạn truy cập quản trị website xem còn cảnh báo không nhé, như hình bên dưới thì đã không còn cảnh báo PHP nữa.

Tổng kết

Như vậy ở bài viết này AZDIGI đã hướng dẫn bạn cách nâng cấp phiên bản PHP để xử lý cảnh báo PHP Update Required trên website WordPress. Dù đây không phải là yêu cầu bắt buộc, nhưng việc bạn nâng cấp PHP sẽ giúp website vận hành tốt tối ưu hơn với các mã nguồn của mình (Theme, Plugin, Core WordPress). Chưa kể đối với một số Plugin,Theme sẽ yêu cầu phiên bản PHP mới để có thể cài đặt được, vì thế việc nâng cấp PHP là điều cần thiết cho website.

Chúc các bạn thực hiện thành công.!

Các bạn có thể tham khảo một số bài viết khác bên dưới